Кодировка koi8-r

ROM-Mail. Внешняя компонента эл. почты
vscooter
Сообщений: 1
Зарегистрирован: 04 ноя 2011, 09:21

Кодировка koi8-r

Сообщение vscooter » 04 ноя 2011, 09:38

Пользуемся, очень активно, модулем ROM-Mail.dll (вер. 1.4.1), но есть одна проблема:

Требуется пересылать файлы но чтобы само письмо (тема и тело) было в кодировке koi8-r, к сожалению
когда прикладываем файл (Почта.Вложения=ФайлВыгрузки;) - кодировка меняется на windows-1251,

Почта.Кодировка="koi8-r"; - не помогает!!!

...
Если ЗагрузитьВнешнююКомпоненту("ROM-Mail.dll")=0 Тогда
сообщить("mail Error;" + "Не удалось загрузить внешнюю компоненту ROM-Mail.dll");
Возврат;
КонецЕсли;
Почта=СоздатьОбъект("AddIn.AddInMail");
Почта.Кодировка="koi8-r";
Почта.СерверОтправки=СокрЛП(СерверОтправки);
Почта.ПортОтправки=ПортОтправки;
Почта.Логин=СокрЛП(Логин);
Почта.Пароль=СокрЛП(Пароль);

Почта.АутентификацияПриОтправке=1;
Если Почта.Соединение=0 Тогда
Если Почта.Подключиться("Отправка")=0 Тогда
сообщить("mail Error;" + "Не удалось подключиться к почтовому серверу");
Возврат;
КонецЕсли;
КонецЕсли;
Почта.АдресОтправителя=СокрЛП(АдресОтправителя);
Почта.ИмяОтправителя=СокрЛП(ИмяОтправителя);
Почта.ДобавитьАдрес("АдресПолучателя",СокрЛП(ИмяПолучателя),СокрЛП(АдресПолучателя));
Почта.Тема=СокрЛП(ТемаПисьма);
Почта.ТипПисьма=0;
Почта.Тело=СокрЛП(Форма.Параметр.ТекстПисьма);
Почта.Вложения=СокрЛП(Форма.Параметр.ФайлВыгрузки);

Если Почта.Соединение=0 Тогда
сообщить("mail Error;" + "Соединение потеряно");
ИначеЕсли Почта.Отправить()=1 Тогда
сообщить("Файл " + СокрЛП(Форма.Параметр.ФайлВыгрузки) + " отправлен на " + АдресПолучателя);
Иначе
сообщить("mail Error;" + "Не удалось отправить сообщение");
КонецЕсли;

Почта.Отключиться();
...
Помогите решить проблему.

Вернуться в «ROM-Mail. Внешняя компонента эл. почты»

cron